Элективный курс по информатике 

«Использование графического редактора Adobe Photoshop при обработке фотографий»

Пояснительная записка.

Данный курс рассчитан на изучение в профильных классах с углубленным изучением информатики. В настоящее время все большее количество людей используют информационные технологии. С появлением доступных сканеров, цифровых фотоаппаратов и видеокамер у людей появилось большое количество цифровых изображений. Это породило потребность в их обработке, восстановлении, создании на их основе новых изображений, фотомонтажей, коллажей и т.д. Изучение графических растровых редакторов позволяет подготовить учащихся для возможной работы в более сложных системах технического конструирования AutoCad (автомобили, летательные аппараты, морские суда, военные корабли), PCad (набор программ для конструирования сложных электронных систем), ArchiCad etc (конструкции зданий, целых городов). 

Элективный курс «Использование графического редактора Adobe Photoshop в обработке фотографий»  способствует развитию познавательной активности учащихся; творческого и операционного мышления; повышению интереса к информатике, а самое главное, профориентации в мире профессий, связанных с использованием знаний этих наук.

Цели: 
· развить интерес к изучению компьютерной графики;
· познакомить с принципами работы растрового графического редактора Photoshop; 

· сформировать понятие безграничных возможностей создания растрового изображения. 
Задачи: 

· дать представление об основных возможностях редактирования и обработки изображения в Adobe Photoshop; 

· научить создавать растровые документы, используя набор инструментов, имеющихся в изучаемом приложении; 

· ознакомить с основными операциями в Adobe Photoshop; 

· способствовать развитию алгоритмического мышления; 

· способствовать развитию познавательного интереса к информатике.
В результате обучения 

· учащиеся должны знать: основы графической среды Photoshop, структуру инструментальной оболочки среды, возможность работы со слоями, наличие фильтров и технология их применения для получения эффектов изображения; оптимизацию растрового изображения для использования его в Интернете; 

· учащиеся должны уметь: создавать и редактировать графические изображения, выполнять типовые действия с объектами и документами в среде Photoshop, подготавливать оптимизированный рисунок для использование его в Интернете; создавать фотомонтажи, коллажи и покадровую анимацию, описывать результаты анализа, обсуждать результаты работы, участвовать в дискуссии. 

Программа элективного курса состоит из четырех разделов: 

1. Знакомство с программой Adobe Photoshop 

2. Основы работы со слоями 
3. Простые способы редактирования 

4. Ретуширование фотографий 

5. Рамки и виньетки 
6. Создание коллажей и карикатур 

7. Создание анимированной графики 

Элективный курс “ Использование графического редактора Adobe Photoshop при обработке фотографий ” рассчитан на 36 часов: 12 часов – теоретических занятий, 21 час - практических работ, 2 часа – создание проекта и 1 час – защита проекта. Курсу отводится 2 часа в неделю для изучения в одном из полугодий 10-го или 11-го класса. 
Тематическое планирование курса

	№
	Тема
	Кол-во часов

	I. Знакомство с программой Adobe Photoshop 

	1
	Основные характеристики растровых изображений
	1

	2
	Основные цветовые модели
	1

	3
	Основные форматы растровой графики
	1

	2. Основы работы со слоями.

	4
	Слои. Эффекты слоя Трансформация слоя.
	1

	5
	Комбинация изображений. Фотомонтаж.
	1

	6
	Создание фотомонтажа с собственным фото.
	1

	7
	Самостоятельная работа по созданию многослойного изображения.
	1

	3. Простые способы редактирования

	1
	Обрезка фотографий. Динамический диапазон и тоновая коррекция
	1

	2
	Изменение яркости и контрастности. Увеличение резкости фотографии
	1

	3
	Цветовые модели и режимы. Цветовая коррекция
	1

	4
	Изменение размеров изображения и разрешения. Кадрирование изображения
	1

	5
	Вращение и зеркальное отражение изображения
	1

	4. Ретуширование фотографий

	1
	Восстановление потерянных фрагментов
	1

	2
	Устранение эффекта красных глаз
	1

	3
	Тонирование изображения и его фрагментов
	1

	5. Рамки, виньетки и кнопки

	1
	Создание виньетки для фотографий
	2

	2
	 Создание рамки для фотографий
	2

	6. Создание коллажей и карикатур. 

	1
	Фильтры. Работа с фильтрами.
	1

	2
	Сепия
	1

	3
	Художественная доводка и обработка фотографий
	1

	4
	Коллаж. Практическая работа по созданию коллажа.
	2

	5
	Текст в Adobe Photoshop. 
	1

	6
	Кнопки. Практическая работа по созданию различных видов кнопок
	1

	7
	Карикатуры
	2

	8
	Создание проекта.
	2

	7. Создание анимированной графики. 

	1
	Создание Gif– анимации: кадры, операции над кадрами, сохранение и загрузка анимации.
	1

	2
	Gif-анимация. Собственный рисунок.
	1

	3
	Создание оригинал-макета открытки.
	1

	4
	Создание проекта “Моя открытка”.
	1

	5
	Защита проекта “Создание макета открытки к празднику”.
	2

	
	
	Всего: 36 ч
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Практическая работа «Создание рамки для фотографий».
Цели:

· Обучающие: Отработать практические навыки при создании рамки в среде Adobe Photoshop CS. 

· Развивающие: Развивать самостоятельность при выполнении практических работ. 

· Воспитательные: Воспитывать творческий подход в выполняемой работе 

Тип урока: практическая работа.

Материалы и оборудование: 

1. класс, оборудованный ПК; 

2. программа Adobe Photoshop CS. 

3. файлы изображений. 

Ход урока 

1. Орг. момент, постановка целей урока. 

2. Объяснение учителем последовательности самостоятельной работы учащихся. 

3. Выполнение практической работы. 

4. Подведение итогов урока. 

Программа Adobe Photoshop предлагает безграничные возможности для  создания и использования различных текстур, создающих эффект имитации различных материалов, таких, как дерево, камень, стекло, пластмасса и т.д., что может пригодится нам при создании окантовки фотографии.

Практическая работа.

Рассмотрим один из способов создания простой рамки.
1.Создадим новый файл. Для этого выберите команду меню 
Файл (File) ->Создать (New).  В диалоговом окне (рис.1) вы должны сообщить данные, необходимые для форматирования документа: его размеры, разрешение и цветовую модель. 
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(рис. 1)

Зададим Ширину (Width) – 640 пикселей (pixels); Высоту (Height) – 480 пикселей (pixels); Содержимое фона – Белый. Щелкните на кнопке Ок.
После создания документа на экране появится окно документа с холстом – белым прямоугольником (рис.2).
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(рис. 2)
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2. Для фона нашей рамки мы можем использовать любые изображения, или любой фон. Давайте выполним заливку цветом переднего плана. Для этого на Панели инструментов (рис.3)  выберем Установки цвета переднего плана и щелкнем по ним левой кнопкой 1 раз. Появится диалоговое окно Сборщик цветов. 

Выберем цвет (например голубой) (рис. 4) и щелкнем кнопку Ок.
[image: image19.png]P Adobe Photoshop.

@afin_PeaakTupsarvie Usofpaxere Cioi Bogenerwe Bwbp Baa ORo Morows

HO}
MY

SN
AORN

=7
0~

B.[7)
WY

@
i

(<]

v

] Ao son,0k0 63

oy i pamral @ 10(

Tnosofi Pasuep | o o0

Coopuy

BLIBEPHTE BT MepeaHera MnaHa

‘é Brushd Tool Presets

Oede

% % O

10
229
243

# [oaEsF3

[ Tonexo web useta

95 |% Ob:

s < %o

&
“a
El
E
0
15
0

Mons3oeatenscit

184 |° OL:

FIES

[ et
=

[C] & e

I

Con

Hopranerait Henpospocre

Bnopoees: ] 4 @ 3

2 0 0 @ o 5

w0

0

e





[image: image20.png]obe Photoshop.

@afin_PeaakTupsarvie Usofpaxere Cioi Bogenerwe Bwbp Baa ORo Morows

O e

&0
A

Ol s

Vicrpyent Samera () (&)

=7 Ol

OHls

cw
RS

[

=]
]

1005 ] Aox: 300,060 635

i pamal ® 100%

b (RGB/8)

D Haxatire Ha xesnaano 06 nacri W3oBpaxerten A1 3anoertis e UeeTon nepeserd rnar, Herionwayiire Shit, At Crl a7 son. o

P [Hopua

epespamecr [1605| permemvecrs 2 | oot D] (3

Eruah]_Tol Prece: Scpoes

3]

wow a5 — = |

Vropna \ Ashcroms

Pl

B
[
]

Cron ™ Kartam “Karrypar

Hopranerart

Snowposra

-

7]

|

&y sanars

=

]

[—
0 7 % @ s o0
-8

2 00 © a5

@

| B adcbertotoshon | B

@





[image: image21.png]obe Photoshop.

@afin_PeaakTupsarvie Usofpaxere Cioi Bogenerwe Bwbp Baa ORo Morows

(DR @ | ercrymenarss ame ] (o526 | crum [opmarmmss S s & o ‘é

Eruah]_Tol Prece: Scpoes

al @ 100% (RGB/B),

3]

wow a5 — = |

X
Veraprn D
&y sanwees
Oy sanwees

[

8 _m

|
o
g
= MK

Con >

Fopanmi v Henpospasocr [0
Sropomcai 0] 4 @ 3on

® |7 &

[ 1000

O o @ o

D Hapicosars MpAMOyTO+HOS SHASNEHM W NSpEMECTHTS SoREAEHE KOHTYPa. Warone3yiiTe SHR, Al n Crl A7 AoromvaTert e oruy

= s | T

1005 ] Aox: 300,060 635




3. На Панели инструментов выберем инструмент для окраски выделенных областей (Градиент или Заливка) (рис.5) и щелкнем по нему. Затем щелкнем на нашем документе по пустой области и наше изображение окрасится в голубой цвет (рис. 6). 
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(рис. 6)
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Выберем на Панели инструментов инструмент Прямоугольная область     (рис. 7).  Установите указатель мыши в угол будущего прямоугольника, щелкните и, не отпуская левую кнопку мыши, тащите в противоположный угол будущего прямоугольника. Когда прямоугольник достигнет нужных размеров, отпустите кнопку мыши  (рис. 8).
(рис. 8)

6. Нажмем кнопку Delete на клавиатуре. Рамка примет следующий вид, который показан на рис. 9.
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(рис. 9)
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7. На Панели инструментов  выберете инструмент Волшебная палочка    и щелкните на голубом пространстве нашей рамки (рис. 11). Через некоторое время, которое потребовалось программе для вычислений, прилегающая часть объекта выделилась – вокруг нее появился мерцающий пунктир.
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(рис. 11)

8. В строке меню Слои -> Дублировать слои (рис. 12). Появится диалоговое окно Копировать слой, щелкните кнопку Ок (рис. 13). 
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(рис. 12)
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(рис. 13)

9. В окне Слои появится Фон копии (рис. 14). Щелкните по нему 2 раза левой кнопкой мыши, появится диалоговое окно Стиль слоя (рис. 15). Настройте по своему усмотрению тени и отблеск.  После этого щелкните Ок. Наша рамка примет вид, как показано на рис.16.
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(рис. 14)
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(рис. 15)

[image: image10.png]r

@afin_PeaakTupsarve Usofpaxere Cioi Bogenerwe Bwbp BAa ORio Morows

R~ |(E@E@

B

Ofpsmsn wyecrauranumocre: [32 | [AHe rpyBo [Henpepuisaii [1cnomsosas sce cnon

AN]0H

= 7|

s

[

L0056 _] Aox: 300,0€/1,76M

——
mycK. 2

I HaXtb1TE A8 4103 CHEXHAX THISCEnEf SXORHMIX USSTOE W MEDEHESTITE KOHTY SHRENEHHA, UEonkzyiTe Shifreemmrere

Eruah]_Tol Prece: Scpoes

U

Veropra

EybmposaTs cron
Crume Cron

Crvme Cron
5 _m 3

Gron

&

Hopmanai | Hempospaocrs: | 1009

Srovpomrai [] o 4+ @ dsmeeai [ 100

=3
e
& ormac e

& Bryroenin T
& B Covr

® & Bryrpe Coar





(рис. 16)
10. Теперь давайте вставим в нашу рамку фотографию. Для этого нужно черную область рамки выделить с помощью инструмента Волшебная палочка (рис. 17). 
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(рис.17)

11. Теперь выберите команду Файл – Открыть. В диалоговом окне выберите фотографию, которую вам нужно вставить в нашу рамку (рис. 18).
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(рис. 18)
12. Выделите всю фотографию, для этого в пункте меню Выделение выберите Все. Теперь в пункте меню Редактирование щелкните Копировать. Затем сделайте активной  вашу рамку, для этого щелкните по ней. 
13. В пункте меню Редактирование щелкните Вставить В.  После этого у вас должно получиться как показано на рис. 19. 
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(рис. 19)

Творческое задание.
Попробуйте создать несколько рамок, используя для заливки изображения фоны и текстуры, а также рисунки, клип-арты и т.п.
На рис. 20 показаны примеры рамок
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(рис. 20)
Практическая работа «Создание различных видов кнопок»
Цели:

· Обучающие: Отработать практические навыки при создании различных видов кнопок в среде Adobe Photoshop CS. 

· Развивающие: Развивать самостоятельность при выполнении практических работ. 

· Воспитательные: Воспитывать творческий подход в выполняемой работе 

Тип урока: практическая работа.

Материалы и оборудование: 

· класс, оборудованный ПК; 

· программа Adobe Photoshop CS; 
· файлы изображений. 

Ход урока 

· Организационный момент, постановка целей урока. 

· Объяснение учителем последовательности самостоятельной работы учащихся. 

· Выполнение практической работы. 

· Подведение итогов урока. 
Задание 1.
 Создание 3-D кнопки. 

1. Создаем новое изображение Файл->Новый (File->New) или нажимаем (Ctrl+N). Например: 50х50 пикс. (pix). Устанавливаем Выберите основной цвет (Foreground) и Выберите цвет фона (Background) цвета в палитре инструментов, например: возьмем красный цвет, как основной, а черный как фоновый. 

2. С помощью инструмента Градиент (Gradient) заполняем наше изображение, например: слева-сверху и вправо-вниз 

[image: image25.png]


3. Затем используем команду Выделение->Все (Select All) ( Ctrl+A ) чтобы выделить область, после этого Выделение -> Модификация - >Граница (Select->Modify->Border) и в поле Ширина (Width ) вводим любое число, например 6. Используем снова инструмент Градиент ( G ), и заполняем в обратном направлении. Потом снимаем выделение ( Ctrl+D ). 

4. Кнопка готова.           
Задание 2.
 Создание круглой 3-D кнопки
1. Создаем новое изображение Файл->Новый (File->New) или ( Ctrl+N ),80х80 пикс.(pix.) на белом фоне. Удерживаем нажатым инструмент Прямоугольная область (Marquee) на клавиатуре ( М ), пока не появится меню и выбираем круг, рисуем круг на изображении. Выбираем Основной (Foreground) и Фоновый (Background ) цвета в палитре инструментов, например: возьмем красный цвет, как основной, а черный как фоновый. 

2. С помощью инструмента Градиент (Gradient) на клавиатуре (G) заполняем наше изображение, например: слева-сверху и вправо-вниз 

3. Используем Выделение->Модификация->Сжать (Select->Modify->Contract) и в поле Ширина (Width) вводим любое число, например 8. Используем снова инструмент Градиент ( G ), и заполняем в обратном направлении. Потом снимаем выделение Выделение-> Отменить выделение (Ctrl+D). 

4. Кнопка готова.

Примечание. Также можно после шага 2 использовать инструмент Выделение (Marquee) на клавиатуре (М) и выделить круг поменьше в центре основного круга, и залить его в обратном направлении эффект будет такой же.

Задание 3.
 Кнопка с использованием текстуры

1. Открываем изображение Файл->Открыть (File->Open) или жмем ( Ctrl+O ) из 

2. Переходим в палитру Слои (Layers). Нажимаем на инструмент внизу окна слоев и создаем Create New Fill or Adjustment Layer (Создать Новый корректирующий слой или слой-заливку). Выбираем параметр Яркость/Контрастность (Brightness/Contrast). 

3. В появившемся окне делаем следующие настройки: Яркость (Brightness) устанавливаем на -60 и нажимаем ОК. 

4. Выполняем Выделение ->Все (Select->All) или нажимаем на клавиатуре ( Сtrl+A ), далее Выделение->Модификация->Граница (Select->Modify->Border) и устанавливаем 25 или другое значение по Выделениеу. Затем Выделение->Сохранить выделенную область (Select->Save Selection), чтобы создать новый канал. 

5. Смотрим чтобы Основной цвет (Foreground ) был черным. Удерживаем Shift и с помощью инструмента Градиент (Gradient) на клавиатуре ( G ) заполняем картинку слева на право. 

6. Выделение->Инверсия (Select->Inverse). Удерживая Shift заполняем инструментом Градиент (G) в обратном направлении справа на лево в выделенной области.

7. Выполняем команду Слой->Объединить с предыдущим (Laers\Merge Layers) или нажимаем (Ctrl+E), чтобы объединить слои. 

8. Экспериментируя можно добиться различных результатов. 

Упражнение 4. Используем Фильтр "Эффекты освещения" для создания кнопки

1. Создаем новое изображение Файл->Новый (File->New) или нажимаем ( Ctrl+N ), в режиме RGB, например 100х100 пикс. (pixels ). Заходим в палитру Каналы (Channels ) и создаем новый канал . Параметры оставляем по умолчанию. 

2. Далее Редактирование->Выполнить заливку... (Edit->Fill) и заливаем белым цветом. 

3. Выполняем Выделение ->Все (Select->All) или нажимаем на клавиатуре ( Сtrl+A ), далее Выделение->Модификация ->Граница (Select->Modify->Border) и устанавливаем 7, или значение по Выделениеу. Ставим Основной цвет (Foreground ) черным, снова Редактирование->Выполнить заливку... (Edit->Fill) но заливаем черным цветом. Жмем Ctrl+D чтобы снять выделение. 

4. Заходим в палитру Слои (Layers ), кликаем по слою чтобы выделить его, и снова Редактирование-> Выполнить заливку... (Edit->Fill) и заливаем любым цветом. 

5. Следующий шаг Фильтр -> Рендеринг -> Эффекты освещения (Filter -> Render -> Lightning Effects). Используем параметры: Стиль как есть, следующее поле тоже оставляем по умолчанию, в поле Свойства параметры: Глянец ставим -36, Материал ставим 69. Далее, где Текстурный канал устанавливаем наш созданный канал в данном случае Aльфа1.В поле Рельеф устанавливаем 33. 

6. Кнопка готова. 

7. Все параметры можно изменять и изменяя цвета заливки можно добиться более красивых результатов. 

Упражнение 5. Используем Фильтр "Эффекты освещения" для создания кнопки из текстуры

1. Открываем картинку Файл->Открыть (File->Open) или жмем ( Ctrl+O )C:\Program Files\Adobe\Photoshop 7.0 CE\Samples\dune.tif. 

2. Выполняем Выделение ->Все (Select->All) или нажимаем на клавиатуре ( Сtrl+A ). Далее Редактирование->Определить узор (Edit->Define Pattern) ОК.

3. Заходим в палитру Каналы (Channels) и создаем новый канал, параметры по умолчанию. Переходим в созданный канал и Редактирование->Выполнить заливку... (Edit->Fill) заливаем белым цветом. 

4. Следующий шаг - Выделение-> Модификация -> Граница (Select->Modify->Border) и устанавливаем 7, устанавливаем Основной (Foreground ) цвет черным, снова Редактирование->Выполнить заливку... (Edit->Fill) но заливаем 50% серым. Снимаем выделение ( Ctrl+D ). 

5. Снова Редактирование->Выполнить заливку... (Edit->Fill), но используем Узор (pattern ) с 50% Непрозрачностью (Opacity) в режиме норма (normal). 

6. Переходим в палитру Слои (Layers ), нажимаем на Слой0 или Задний план (двойным щелчком делаем его редактируемым), и затем Фильтр->Рендеринг->Эффекты освещения (Filter->Render->Lightning Effects). Используем параметры: Стиль как есть. Яркость ставим 18, Фокус ставим 69. Далее Глянец -56, Материал 100, Экспонир. 0, Среда 0. Где Текстурный канал устанавливаем созданный канал Aльфa1, и Высота 75. 

7. Переместите узлы светового пятна прожектора. Поэкспериментируйте с параметрами получается много интересных вариантов.
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(Рис. 3)








(рис. 4)








